Après moult péripéties (un nouveau travail, un déménagement de l’autre côté du pays, ...) ; j’ai finalement réussi à trouver assez de temps pour travailler un peu sur le projet, et sortir une nouvelle version corrective !

Pas mal de choses ont été corrigées, consultez la liste des modifications pour une liste exhaustive.

Le seul changement qui ne soit pas à proprement parler un bogue ne concerne que les personnes qui sont hébergées sur un serveur qui utilise Debian Squeeze, et sa version PHP 5.3.3 patchée. Je rappelle que Galette requiert désormais PHP en version 5.3.7 au moins, et qu’il est plus que fortement conseillé de mettre à jour votre version de PHP si ce pré-requis n’est pas satisfait ; toute autre solution relève davantage du « bricolage » qu’autre chose.

Néanmoins, des distributions relativement répandues sur les serveurs d’hébergement, telles que Debian Squeeze ou RHEL 6 ne fournissent pas de version de PHP supérieure à 5.3.3, mais y incluent les patchs de sécurité à postériori. Le problème, c’est que Debian n’a pas inclus tous les patches nécessaires.
Une vérification a par conséquent été ajoutée dans le processus d’installation pour détecter les cas qui ne fonctionneraient pas, et une solution de contournement a été mise en place.